2014/08/19 このエントリーをはてなブックマークに追加 はてなブックマーク - 【Glassfish4】EclipseからGlassfishが起動出来ない(サーバーアダプターが見つからない)

【Glassfish4】EclipseからGlassfishが起動出来ない(サーバーアダプターが見つからない)





Glassfish4をEcllipseから起動しようしても、サーバーアダプターが現れてくれない。



  • Eclipse Luna
  • Glassfish4
  • マーケットプレースより、Glassfish4.xプラグイン導入済み



  • EclipseにGlassfish4対応のプラグインをインストールしたはずなのに、
    サーバのビューで新規サーバを立てようとしても、Glassfishサーバが候補として出てこない。
    プラグインが丸々インストールされていないかのように見える。




  • EclipseをJava7で起動する

  • 具体的にはこんな感じ。
    eclipse.exe -clean -vm "{JAVA_HOME}/bin/javaw.exe"


    Java6とか複数のJavaバージョンが混在している場合に起こる可能性のある問題。
    明示的にvmを指定するのが最も平和的な解決な気がする。



  • Glassfish4はJava7以上でしか動かないよ
  • EclipseもJava7以上で起動しないとGlassfish4がガン無視されるよ
  • Java7以外のランタイム環境を全てアンインストールするのも方法としてあるけど、 Eclipse起動時にvm指定した方が平和的
  • vmオプションはeclipse.iniに書いても良いと思う









  • 0 件のコメント:

    コメントを投稿